Friendhosting LTD - Power Issue at NL2 Meppel Data Center – Incident details

Power Issue at NL2 Meppel Data Center

Resolved
Operational
Started 2 months agoLasted about 4 hours

Affected

European Location (data center)

Operational from 1:45 PM to 3:02 PM, Major outage from 3:02 PM to 5:33 PM

Serverius (Netherlands)

Operational from 1:45 PM to 3:02 PM, Major outage from 3:02 PM to 5:33 PM

Updates
  • Resolved
    Resolved

    We are pleased to inform you that the power outage at the Serverius NL2 Meppel Data Center has been resolved and power has been fully restored.

  • Update
    Update

    UDP: the issue is still under investigation, Power Feed A and B are affected at the Serverius NL2 facility.

  • Identified
    Identified

    Update from datacenter staff: "There is currently an issue affecting Power Feed A at the Serverius NL2 facility. Our Support and Facility teams are actively investigating and working to resolve the problem as quickly as possible. We will keep you updated on our progress. Thank you for your understanding and patience."

  • Investigating
    Investigating

    Dear Customer,

    We are writing to inform you of an ongoing power outage at the Serverius NL2 Meppel data center.

    Location: NL2, Meppel, NL

    Start Time: 28 April 2025, 15:45 CEST

    Estimated End Time: To be determined

    Reason:

    There is currently an issue affecting Power Feed A at the Serverius NL2 facility. Our Support and Facility teams are actively investigating and working to resolve the problem as quickly as possible.

    We will keep you updated on our progress.

    Thank you for your understanding and patience.

    Best regards,

    The Friendhosting LTD Team